MikroTik Ethernet Error Detection


#########################################################################################################
# MikroTik Ethernet Error Detection #
#########################################################################################################
# Author: Rick Frey #
# email: support@rickfreyconsulting.com #
# Username in MikroTik Forum is rickfrey #
######################################################################################################### #
#########################################################################################################
# Features # #
# -Runs script every 6 hours to look for 21 Ethernet conditions that may help identify problems. #
# -Sends an email when problems are detected. You must specify the address to send to. #
# -May generate multiple emails for the same interface if it is having problems. #
#########################################################################################################

############################################################################################################################
#### The email tool needs to be already configured to use this script (tool e-mail). ##
############################################################################################################################

/system scheduler
add interval=6h name=”Schedule Ethernet Error Detection” on-event=”/system script run Ethernet_Error_Detection_Ether1 \r\
\n/system script run Ethernet_Error_Detection_Ether2\r\
\n/system script run Ethernet_Error_Detection_Ether3 \r\
\n/system script run Ethernet_Error_Detection_Ether4 \r\
\n/system script run Ethernet_Error_Detection_Ether5 \r\
\n/system script run Ethernet_Error_Detection_Ether6 \r\
\n/system script run Ethernet_Error_Detection_Ether7 \r\
\n/system script run Ethernet_Error_Detection_Ether8 \r\
\n/system script run Ethernet_Error_Detection_Ether9 \r\
\n/system script run Ethernet_Error_Detection_Ether10 \r\
\n/system script run Ethernet_Error_Detection_Ether11\r\
\n/system script run Ethernet_Error_Detection_Ether12\r\
\n/system script run Ethernet_Error_Detection_Ether13\r\
\n” policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=may/15/2018 start-time=00:00:00

####Ether1####
/system script
add name=Ethernet_Error_Detection_Ether1 owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source={
:global sysname [/system identity get name]
#Check MTU Size
:if ([/interface ethernet get ether1 value-name=mtu] =1500) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
#Check to see if ARP is enabled
:if ([/interface ethernet get ether1 value-name=arp] =”enabled”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
#Check to see if auto negotiation has settled on the correct speed. Change speed as needed.
:if ([/interface ethernet get ether1 value-name=speed] =”100Mbps”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
#Check to see if the connection is in full duplex
:if ([/interface ethernet get ether1 value-name=full-duplex] =true) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}

#Check RX Stats
:if ([/interface ethernet get ether1 value-name=rx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
:if ([/interface ethernet get ether1 value-name=rx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
:if ([/interface ethernet get ether1 value-name=rx-fcs-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
:if ([/interface ethernet get ether1 value-name=rx-align-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
:if ([/interface ethernet get ether1 value-name=rx-too-short] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
:if ([/interface ethernet get ether1 value-name=rx-fragment] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
:if ([/interface ethernet get ether1 value-name=rx-overflow] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}

#Check TX Stats
:if ([/interface ethernet get ether1 value-name=tx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
:if ([/interface ethernet get ether1 value-name=tx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
:if ([/interface ethernet get ether1 value-name=tx-underrun] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
:if ([/interface ethernet get ether1 value-name=tx-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
:if ([/interface ethernet get ether1 value-name=tx-excessive-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
:if ([/interface ethernet get ether1 value-name=tx-multiple-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
:if ([/interface ethernet get ether1 value-name=tx-single-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
:if ([/interface ethernet get ether1 value-name=tx-excessive-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
:if ([/interface ethernet get ether1 value-name=tx-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
:if ([/interface ethernet get ether1 value-name=tx-late-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether1″ body=”Ethernet errors were detected on $sysname Ether1″]}
}
/

####Ether2####
/system script
add name=Ethernet_Error_Detection_Ether2 owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source={
:global sysname [/system identity get name]
#Check MTU Size
:if ([/interface ethernet get ether2 value-name=mtu] =1500) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
#Check to see if ARP is enabled
:if ([/interface ethernet get ether2 value-name=arp] =”enabled”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
#Check to see if auto negotiation has settled on the correct speed. Change speed as needed.
:if ([/interface ethernet get ether2 value-name=speed] =”100Mbps”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
#Check to see if the connection is in full duplex
:if ([/interface ethernet get ether2 value-name=full-duplex] =true) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}

#Check RX Stats
:if ([/interface ethernet get ether2 value-name=rx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
:if ([/interface ethernet get ether2 value-name=rx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
:if ([/interface ethernet get ether2 value-name=rx-fcs-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
:if ([/interface ethernet get ether2 value-name=rx-align-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
:if ([/interface ethernet get ether2 value-name=rx-too-short] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
:if ([/interface ethernet get ether2 value-name=rx-fragment] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
:if ([/interface ethernet get ether2 value-name=rx-overflow] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}

#Check TX Stats
:if ([/interface ethernet get ether2 value-name=tx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
:if ([/interface ethernet get ether2 value-name=tx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
:if ([/interface ethernet get ether2 value-name=tx-underrun] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
:if ([/interface ethernet get ether2 value-name=tx-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
:if ([/interface ethernet get ether2 value-name=tx-excessive-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
:if ([/interface ethernet get ether2 value-name=tx-multiple-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
:if ([/interface ethernet get ether2 value-name=tx-single-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
:if ([/interface ethernet get ether2 value-name=tx-excessive-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
:if ([/interface ethernet get ether2 value-name=tx-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
:if ([/interface ethernet get ether2 value-name=tx-late-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether2″ body=”Ethernet errors were detected on $sysname Ether2″]}
}
/

####Ether3####
/system script
add name=Ethernet_Error_Detection_Ether3 owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source={
:global sysname [/system identity get name]
#Check MTU Size
:if ([/interface ethernet get ether3 value-name=mtu] =1500) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
#Check to see if ARP is enabled
:if ([/interface ethernet get ether3 value-name=arp] =”enabled”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
#Check to see if auto negotiation has settled on the correct speed. Change speed as needed.
:if ([/interface ethernet get ether3 value-name=speed] =”100Mbps”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
#Check to see if the connection is in full duplex
:if ([/interface ethernet get ether3 value-name=full-duplex] =true) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}

#Check RX Stats
:if ([/interface ethernet get ether3 value-name=rx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
:if ([/interface ethernet get ether3 value-name=rx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
:if ([/interface ethernet get ether3 value-name=rx-fcs-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
:if ([/interface ethernet get ether3 value-name=rx-align-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
:if ([/interface ethernet get ether3 value-name=rx-too-short] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
:if ([/interface ethernet get ether3 value-name=rx-fragment] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
:if ([/interface ethernet get ether3 value-name=rx-overflow] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}

#Check TX Stats
:if ([/interface ethernet get ether3 value-name=tx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
:if ([/interface ethernet get ether3 value-name=tx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
:if ([/interface ethernet get ether3 value-name=tx-underrun] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
:if ([/interface ethernet get ether3 value-name=tx-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
:if ([/interface ethernet get ether3 value-name=tx-excessive-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
:if ([/interface ethernet get ether3 value-name=tx-multiple-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
:if ([/interface ethernet get ether3 value-name=tx-single-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
:if ([/interface ethernet get ether3 value-name=tx-excessive-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
:if ([/interface ethernet get ether3 value-name=tx-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
:if ([/interface ethernet get ether3 value-name=tx-late-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether3″ body=”Ethernet errors were detected on $sysname Ether3″]}
}
/

####Ether4####
/system script
add name=Ethernet_Error_Detection_Ether4 owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source={
:global sysname [/system identity get name]
#Check MTU Size
:if ([/interface ethernet get ether4 value-name=mtu] =1500) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
#Check to see if ARP is enabled
:if ([/interface ethernet get ether4 value-name=arp] =”enabled”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
#Check to see if auto negotiation has settled on the correct speed. Change speed as needed.
:if ([/interface ethernet get ether4 value-name=speed] =”100Mbps”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
#Check to see if the connection is in full duplex
:if ([/interface ethernet get ether4 value-name=full-duplex] =true) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}

#Check RX Stats
:if ([/interface ethernet get ether4 value-name=rx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
:if ([/interface ethernet get ether4 value-name=rx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
:if ([/interface ethernet get ether4 value-name=rx-fcs-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
:if ([/interface ethernet get ether4 value-name=rx-align-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
:if ([/interface ethernet get ether4 value-name=rx-too-short] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
:if ([/interface ethernet get ether4 value-name=rx-fragment] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
:if ([/interface ethernet get ether4 value-name=rx-overflow] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}

#Check TX Stats
:if ([/interface ethernet get ether4 value-name=tx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
:if ([/interface ethernet get ether4 value-name=tx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
:if ([/interface ethernet get ether4 value-name=tx-underrun] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
:if ([/interface ethernet get ether4 value-name=tx-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
:if ([/interface ethernet get ether4 value-name=tx-excessive-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
:if ([/interface ethernet get ether4 value-name=tx-multiple-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
:if ([/interface ethernet get ether4 value-name=tx-single-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
:if ([/interface ethernet get ether4 value-name=tx-excessive-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
:if ([/interface ethernet get ether4 value-name=tx-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
:if ([/interface ethernet get ether4 value-name=tx-late-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether4″ body=”Ethernet errors were detected on $sysname Ether4″]}
}
/

####Ether5####
/system script
add name=Ethernet_Error_Detection_Ether5 owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source={
:global sysname [/system identity get name]
#Check MTU Size
:if ([/interface ethernet get ether5 value-name=mtu] =1500) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
#Check to see if ARP is enabled
:if ([/interface ethernet get ether5 value-name=arp] =”enabled”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
#Check to see if auto negotiation has settled on the correct speed. Change speed as needed.
:if ([/interface ethernet get ether5 value-name=speed] =”100Mbps”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
#Check to see if the connection is in full duplex
:if ([/interface ethernet get ether5 value-name=full-duplex] =true) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}

#Check RX Stats
:if ([/interface ethernet get ether5 value-name=rx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
:if ([/interface ethernet get ether5 value-name=rx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
:if ([/interface ethernet get ether5 value-name=rx-fcs-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
:if ([/interface ethernet get ether5 value-name=rx-align-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
:if ([/interface ethernet get ether5 value-name=rx-too-short] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
:if ([/interface ethernet get ether5 value-name=rx-fragment] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
:if ([/interface ethernet get ether5 value-name=rx-overflow] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}

#Check TX Stats
:if ([/interface ethernet get ether5 value-name=tx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
:if ([/interface ethernet get ether5 value-name=tx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
:if ([/interface ethernet get ether5 value-name=tx-underrun] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
:if ([/interface ethernet get ether5 value-name=tx-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
:if ([/interface ethernet get ether5 value-name=tx-excessive-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
:if ([/interface ethernet get ether5 value-name=tx-multiple-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
:if ([/interface ethernet get ether5 value-name=tx-single-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
:if ([/interface ethernet get ether5 value-name=tx-excessive-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
:if ([/interface ethernet get ether5 value-name=tx-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
:if ([/interface ethernet get ether5 value-name=tx-late-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether5″ body=”Ethernet errors were detected on $sysname Ether5″]}
}
/

####Ether6####
/system script
add name=Ethernet_Error_Detection_Ether6 owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source={
:global sysname [/system identity get name]
#Check MTU Size
:if ([/interface ethernet get ether6 value-name=mtu] =1500) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
#Check to see if ARP is enabled
:if ([/interface ethernet get ether6 value-name=arp] =”enabled”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
#Check to see if auto negotiation has settled on the correct speed. Change speed as needed.
:if ([/interface ethernet get ether6 value-name=speed] =”100Mbps”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
#Check to see if the connection is in full duplex
:if ([/interface ethernet get ether6 value-name=full-duplex] =true) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}

#Check RX Stats
:if ([/interface ethernet get ether6 value-name=rx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
:if ([/interface ethernet get ether6 value-name=rx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
:if ([/interface ethernet get ether6 value-name=rx-fcs-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
:if ([/interface ethernet get ether6 value-name=rx-align-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
:if ([/interface ethernet get ether6 value-name=rx-too-short] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
:if ([/interface ethernet get ether6 value-name=rx-fragment] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
:if ([/interface ethernet get ether6 value-name=rx-overflow] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}

#Check TX Stats
:if ([/interface ethernet get ether6 value-name=tx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
:if ([/interface ethernet get ether6 value-name=tx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
:if ([/interface ethernet get ether6 value-name=tx-underrun] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
:if ([/interface ethernet get ether6 value-name=tx-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
:if ([/interface ethernet get ether6 value-name=tx-excessive-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
:if ([/interface ethernet get ether6 value-name=tx-multiple-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
:if ([/interface ethernet get ether6 value-name=tx-single-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
:if ([/interface ethernet get ether6 value-name=tx-excessive-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
:if ([/interface ethernet get ether6 value-name=tx-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
:if ([/interface ethernet get ether6 value-name=tx-late-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether6″ body=”Ethernet errors were detected on $sysname Ether6″]}
}
/

####Ether7####
/system script
add name=Ethernet_Error_Detection_Ether7 owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source={
:global sysname [/system identity get name]
#Check MTU Size
:if ([/interface ethernet get ether7 value-name=mtu] =1500) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
#Check to see if ARP is enabled
:if ([/interface ethernet get ether7 value-name=arp] =”enabled”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
#Check to see if auto negotiation has settled on the correct speed. Change speed as needed.
:if ([/interface ethernet get ether7 value-name=speed] =”100Mbps”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
#Check to see if the connection is in full duplex
:if ([/interface ethernet get ether7 value-name=full-duplex] =true) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}

#Check RX Stats
:if ([/interface ethernet get ether7 value-name=rx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
:if ([/interface ethernet get ether7 value-name=rx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
:if ([/interface ethernet get ether7 value-name=rx-fcs-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
:if ([/interface ethernet get ether7 value-name=rx-align-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
:if ([/interface ethernet get ether7 value-name=rx-too-short] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
:if ([/interface ethernet get ether7 value-name=rx-fragment] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
:if ([/interface ethernet get ether7 value-name=rx-overflow] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}

#Check TX Stats
:if ([/interface ethernet get ether7 value-name=tx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
:if ([/interface ethernet get ether7 value-name=tx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
:if ([/interface ethernet get ether7 value-name=tx-underrun] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
:if ([/interface ethernet get ether7 value-name=tx-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
:if ([/interface ethernet get ether7 value-name=tx-excessive-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
:if ([/interface ethernet get ether7 value-name=tx-multiple-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
:if ([/interface ethernet get ether7 value-name=tx-single-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
:if ([/interface ethernet get ether7 value-name=tx-excessive-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
:if ([/interface ethernet get ether7 value-name=tx-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
:if ([/interface ethernet get ether7 value-name=tx-late-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether7″ body=”Ethernet errors were detected on $sysname Ether7″]}
}
/

####Ether8####
/system script
add name=Ethernet_Error_Detection_Ether8 owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source={
:global sysname [/system identity get name]
#Check MTU Size
:if ([/interface ethernet get ether8 value-name=mtu] =1500) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
#Check to see if ARP is enabled
:if ([/interface ethernet get ether8 value-name=arp] =”enabled”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
#Check to see if auto negotiation has settled on the correct speed. Change speed as needed.
:if ([/interface ethernet get ether8 value-name=speed] =”100Mbps”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
#Check to see if the connection is in full duplex
:if ([/interface ethernet get ether8 value-name=full-duplex] =true) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}

#Check RX Stats
:if ([/interface ethernet get ether8 value-name=rx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
:if ([/interface ethernet get ether8 value-name=rx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
:if ([/interface ethernet get ether8 value-name=rx-fcs-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
:if ([/interface ethernet get ether8 value-name=rx-align-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
:if ([/interface ethernet get ether8 value-name=rx-too-short] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
:if ([/interface ethernet get ether8 value-name=rx-fragment] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
:if ([/interface ethernet get ether8 value-name=rx-overflow] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}

#Check TX Stats
:if ([/interface ethernet get ether8 value-name=tx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
:if ([/interface ethernet get ether8 value-name=tx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
:if ([/interface ethernet get ether8 value-name=tx-underrun] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
:if ([/interface ethernet get ether8 value-name=tx-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
:if ([/interface ethernet get ether8 value-name=tx-excessive-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
:if ([/interface ethernet get ether8 value-name=tx-multiple-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
:if ([/interface ethernet get ether8 value-name=tx-single-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
:if ([/interface ethernet get ether8 value-name=tx-excessive-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
:if ([/interface ethernet get ether8 value-name=tx-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
:if ([/interface ethernet get ether8 value-name=tx-late-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether8″ body=”Ethernet errors were detected on $sysname Ether8″]}
}
/

####Ether9####
/system script
add name=Ethernet_Error_Detection_Ether9 owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source={
:global sysname [/system identity get name]
#Check MTU Size
:if ([/interface ethernet get ether9 value-name=mtu] =1500) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
#Check to see if ARP is enabled
:if ([/interface ethernet get ether9 value-name=arp] =”enabled”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
#Check to see if auto negotiation has settled on the correct speed. Change speed as needed.
:if ([/interface ethernet get ether9 value-name=speed] =”100Mbps”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
#Check to see if the connection is in full duplex
:if ([/interface ethernet get ether9 value-name=full-duplex] =true) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}

#Check RX Stats
:if ([/interface ethernet get ether9 value-name=rx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
:if ([/interface ethernet get ether9 value-name=rx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
:if ([/interface ethernet get ether9 value-name=rx-fcs-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
:if ([/interface ethernet get ether9 value-name=rx-align-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
:if ([/interface ethernet get ether9 value-name=rx-too-short] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
:if ([/interface ethernet get ether9 value-name=rx-fragment] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
:if ([/interface ethernet get ether9 value-name=rx-overflow] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}

#Check TX Stats
:if ([/interface ethernet get ether9 value-name=tx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
:if ([/interface ethernet get ether9 value-name=tx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
:if ([/interface ethernet get ether9 value-name=tx-underrun] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
:if ([/interface ethernet get ether9 value-name=tx-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
:if ([/interface ethernet get ether9 value-name=tx-excessive-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
:if ([/interface ethernet get ether9 value-name=tx-multiple-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
:if ([/interface ethernet get ether9 value-name=tx-single-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
:if ([/interface ethernet get ether9 value-name=tx-excessive-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
:if ([/interface ethernet get ether9 value-name=tx-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
:if ([/interface ethernet get ether9 value-name=tx-late-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether9″ body=”Ethernet errors were detected on $sysname Ether9″]}
}
/

####Ether10####
/system script
add name=Ethernet_Error_Detection_Ether10 owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source={
:global sysname [/system identity get name]
#Check MTU Size
:if ([/interface ethernet get ether10 value-name=mtu] =1500) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
#Check to see if ARP is enabled
:if ([/interface ethernet get ether10 value-name=arp] =”enabled”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
#Check to see if auto negotiation has settled on the correct speed. Change speed as needed.
:if ([/interface ethernet get ether10 value-name=speed] =”100Mbps”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
#Check to see if the connection is in full duplex
:if ([/interface ethernet get ether10 value-name=full-duplex] =true) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}

#Check RX Stats
:if ([/interface ethernet get ether10 value-name=rx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
:if ([/interface ethernet get ether10 value-name=rx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
:if ([/interface ethernet get ether10 value-name=rx-fcs-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
:if ([/interface ethernet get ether10 value-name=rx-align-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
:if ([/interface ethernet get ether10 value-name=rx-too-short] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
:if ([/interface ethernet get ether10 value-name=rx-fragment] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
:if ([/interface ethernet get ether10 value-name=rx-overflow] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}

#Check TX Stats
:if ([/interface ethernet get ether10 value-name=tx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
:if ([/interface ethernet get ether10 value-name=tx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
:if ([/interface ethernet get ether10 value-name=tx-underrun] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
:if ([/interface ethernet get ether10 value-name=tx-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
:if ([/interface ethernet get ether10 value-name=tx-excessive-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
:if ([/interface ethernet get ether10 value-name=tx-multiple-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
:if ([/interface ethernet get ether10 value-name=tx-single-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
:if ([/interface ethernet get ether10 value-name=tx-excessive-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
:if ([/interface ethernet get ether10 value-name=tx-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
:if ([/interface ethernet get ether10 value-name=tx-late-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether10″ body=”Ethernet errors were detected on $sysname Ether10″]}
}
/

####Ether11####
/system script
add name=Ethernet_Error_Detection_Ether11 owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source={
:global sysname [/system identity get name]
#Check MTU Size
:if ([/interface ethernet get ether11 value-name=mtu] =1500) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
#Check to see if ARP is enabled
:if ([/interface ethernet get ether11 value-name=arp] =”enabled”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
#Check to see if auto negotiation has settled on the correct speed. Change speed as needed.
:if ([/interface ethernet get ether11 value-name=speed] =”100Mbps”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
#Check to see if the connection is in full duplex
:if ([/interface ethernet get ether11 value-name=full-duplex] =true) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}

#Check RX Stats
:if ([/interface ethernet get ether11 value-name=rx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
:if ([/interface ethernet get ether11 value-name=rx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
:if ([/interface ethernet get ether11 value-name=rx-fcs-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
:if ([/interface ethernet get ether11 value-name=rx-align-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
:if ([/interface ethernet get ether11 value-name=rx-too-short] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
:if ([/interface ethernet get ether11 value-name=rx-fragment] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
:if ([/interface ethernet get ether11 value-name=rx-overflow] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}

#Check TX Stats
:if ([/interface ethernet get ether11 value-name=tx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
:if ([/interface ethernet get ether11 value-name=tx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
:if ([/interface ethernet get ether11 value-name=tx-underrun] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
:if ([/interface ethernet get ether11 value-name=tx-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
:if ([/interface ethernet get ether11 value-name=tx-excessive-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
:if ([/interface ethernet get ether11 value-name=tx-multiple-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
:if ([/interface ethernet get ether11 value-name=tx-single-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
:if ([/interface ethernet get ether11 value-name=tx-excessive-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
:if ([/interface ethernet get ether11 value-name=tx-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
:if ([/interface ethernet get ether11 value-name=tx-late-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether11″ body=”Ethernet errors were detected on $sysname Ether11″]}
}
/

####Ether12####
/system script
add name=Ethernet_Error_Detection_Ether12 owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source={
:global sysname [/system identity get name]
#Check MTU Size
:if ([/interface ethernet get ether12 value-name=mtu] =1500) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
#Check to see if ARP is enabled
:if ([/interface ethernet get ether12 value-name=arp] =”enabled”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
#Check to see if auto negotiation has settled on the correct speed. Change speed as needed.
:if ([/interface ethernet get ether12 value-name=speed] =”100Mbps”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
#Check to see if the connection is in full duplex
:if ([/interface ethernet get ether12 value-name=full-duplex] =true) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}

#Check RX Stats
:if ([/interface ethernet get ether12 value-name=rx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
:if ([/interface ethernet get ether12 value-name=rx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
:if ([/interface ethernet get ether12 value-name=rx-fcs-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
:if ([/interface ethernet get ether12 value-name=rx-align-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
:if ([/interface ethernet get ether12 value-name=rx-too-short] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
:if ([/interface ethernet get ether12 value-name=rx-fragment] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
:if ([/interface ethernet get ether12 value-name=rx-overflow] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}

#Check TX Stats
:if ([/interface ethernet get ether12 value-name=tx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
:if ([/interface ethernet get ether12 value-name=tx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
:if ([/interface ethernet get ether12 value-name=tx-underrun] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
:if ([/interface ethernet get ether12 value-name=tx-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
:if ([/interface ethernet get ether12 value-name=tx-excessive-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
:if ([/interface ethernet get ether12 value-name=tx-multiple-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
:if ([/interface ethernet get ether12 value-name=tx-single-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
:if ([/interface ethernet get ether12 value-name=tx-excessive-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
:if ([/interface ethernet get ether12 value-name=tx-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
:if ([/interface ethernet get ether12 value-name=tx-late-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether12″ body=”Ethernet errors were detected on $sysname Ether12″]}
}
/

####Ether13####
/system script
add name=Ethernet_Error_Detection_Ether13 owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source={
:global sysname [/system identity get name]
#Check MTU Size
:if ([/interface ethernet get ether13 value-name=mtu] =1500) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
#Check to see if ARP is enabled
:if ([/interface ethernet get ether13 value-name=arp] =”enabled”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
#Check to see if auto negotiation has settled on the correct speed. Change speed as needed.
:if ([/interface ethernet get ether13 value-name=speed] =”100Mbps”) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
#Check to see if the connection is in full duplex
:if ([/interface ethernet get ether13 value-name=full-duplex] =true) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}

#Check RX Stats
:if ([/interface ethernet get ether13 value-name=rx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
:if ([/interface ethernet get ether13 value-name=rx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
:if ([/interface ethernet get ether13 value-name=rx-fcs-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
:if ([/interface ethernet get ether13 value-name=rx-align-error] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
:if ([/interface ethernet get ether13 value-name=rx-too-short] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
:if ([/interface ethernet get ether13 value-name=rx-fragment] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
:if ([/interface ethernet get ether13 value-name=rx-overflow] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}

#Check TX Stats
:if ([/interface ethernet get ether13 value-name=tx-too-long] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
:if ([/interface ethernet get ether13 value-name=tx-pause] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
:if ([/interface ethernet get ether13 value-name=tx-underrun] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
:if ([/interface ethernet get ether13 value-name=tx-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
:if ([/interface ethernet get ether13 value-name=tx-excessive-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
:if ([/interface ethernet get ether13 value-name=tx-multiple-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
:if ([/interface ethernet get ether13 value-name=tx-single-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
:if ([/interface ethernet get ether13 value-name=tx-excessive-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
:if ([/interface ethernet get ether13 value-name=tx-deferred] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
:if ([/interface ethernet get ether13 value-name=tx-late-collision] =0) do={} else={[/log error message=”Check Ethernet ports!”
/tool e-mail send to=rickfrey1000@gmail.com subject=”Ethernet Errors Detected on Ether13″ body=”Ethernet errors were detected on $sysname Ether13″]}
}
/

 

MikroTik Ethernet Error Detection

Leave a comment

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>