Convert L3 QoS to L2 QoS Rev 1.0


#########################################################################################################
# Convert L3 QoS to L2 QoS Rev 1.0 #
#########################################################################################################
# Author: Rick Frey #
# email: support@rickfreyconsulting.com #
# Username in MikroTik Forum is rickfrey #
#########################################################################################################
# License #
# This script has been created for use by the general public and may be used freely. This script may #
# not be sold! #
#########################################################################################################
# Features #
# -Converts the QoS value from the L3 ToS/ DSCP value in the packet to the L2 header of a frame #
#########################################################################################################

######################################################################################################################
/ip firewall mangle
add action=set-priority chain=prerouting comment=”Transfer L3 QoS (ToS/DSCP) value of 7 to L2 QoS (Priority) value of 7″ dscp=7 new-priority=7 passthrough=yes
add action=set-priority chain=prerouting comment=”Transfer L3 QoS (ToS/DSCP) value of 6 to L2 QoS (Priority) value of 6″ dscp=6 new-priority=6 passthrough=yes
add action=set-priority chain=prerouting comment=”Transfer L3 QoS (ToS/DSCP) value of 5 to L2 QoS (Priority) value of 5″ dscp=5 new-priority=5 passthrough=yes
add action=set-priority chain=prerouting comment=”Transfer L3 QoS (ToS/DSCP) value of 4 to L2 QoS (Priority) value of 4″ dscp=4 new-priority=4 passthrough=yes
add action=set-priority chain=prerouting comment=”Transfer L3 QoS (ToS/DSCP) value of 3 to L2 QoS (Priority) value of 3″ dscp=3 new-priority=3 passthrough=yes
add action=set-priority chain=prerouting comment=”Transfer L3 QoS (ToS/DSCP) value of 2 to L2 QoS (Priority) value of 2″ dscp=2 new-priority=2 passthrough=yes
add action=set-priority chain=prerouting comment=”Transfer L3 QoS (ToS/DSCP) value of 1 to L2 QoS (Priority) value of 1″ dscp=1 new-priority=1 passthrough=yes
add action=set-priority chain=prerouting comment=”Transfer L3 QoS (ToS/DSCP) value of 0 to L2 QoS (Priority) value of 0″ dscp=0 new-priority=0 passthrough=yes
/

Convert L3 QoS to L2 QoS Rev 1.0

Leave a comment

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.