































![]()
EtherType Table
SAP Codes
| Hex | Meaning |
| 0x00 | Null LSAP |
| 0x02 | Individual LLC Sublayer Mgt |
| 0x03 | Group LLC Sublayer Management Function |
| 0x04 | SNA Path Control (individual) |
| 0x05 | IBM SNA Path Control (group) |
| 0x06 | Reserved for DoD IP |
| 0x08 | SNA |
| 0x0E | ProWay-LAN |
| 0x18 | Texas Instruments |
| 0x42 | IEEE 802.1 Bridge Spanning Tree Protocol |
| 0x4E | EIA-RS 511 |
| 0x5E | ISI IP |
| 0x7E | ISO 8208 (X.25 over IEEE 802.2 Type LLC) |
| 0x80 | Xerox Network Systems (XNS) |
| 0x82 | BACnet/Ethernet |
| 0x86 | Nestar |
| 0x8E | ProWay-LAN (IEC 955) |
| 0x98 | ARPANET Address Resolution Protocol (ARP) |
| 0xA6 | RDE (route determination entity) |
| 0xAA | SNAP Extension Used |
| 0xBC | Banyan Vines |
| 0xE0 | Novell NetWare |
| 0xF0 | IBM NetBIOS |
| 0xF4 | IBM LAN Management (individual) |
| 0xF8 | IBM Remote Program Load (RPL) |
| 0xFA | Ungermann-Bass |
| 0xFE | OSI protocols ISO CLNS IS 8473 |
ARP Operation Codes
| Number |
|
|
||
| 0 | Reserved | [RFC5494] | ||
| 1 | REQUEST | [RFC826][RFC5227] | ||
| 2 | REPLY | [RFC826][RFC5227] | ||
| 3 | request Reverse | [RFC903] | ||
| 4 | reply Reverse | [RFC903] | ||
| 5 | DRARP-Request | [RFC1931] | ||
| 6 | DRARP-Reply | [RFC1931] | ||
| 7 | DRARP-Error | [RFC1931] | ||
| 8 | InARP-Request | [RFC2390] | ||
| 9 | InARP-Reply | [RFC2390] | ||
| 10 | ARP-NAK | [RFC1577] | ||
| 11 | MARS-Request | [Grenville_Armitage] | ||
| 12 | MARS-Multi | [Grenville_Armitage] | ||
| 13 | MARS-MServ | [Grenville_Armitage] | ||
| 14 | MARS-Join | [Grenville_Armitage] | ||
| 15 | MARS-Leave | [Grenville_Armitage] | ||
| 16 | MARS-NAK | [Grenville_Armitage] | ||
| 17 | MARS-Unserv | [Grenville_Armitage] | ||
| 18 | MARS-SJoin | [Grenville_Armitage] | ||
| 19 | MARS-SLeave | [Grenville_Armitage] | ||
| 20 | MARS-Grouplist-Request | [Grenville_Armitage] | ||
| 21 | MARS-Grouplist-Reply | [Grenville_Armitage] | ||
| 22 | MARS-Redirect-Map | [Grenville_Armitage] | ||
| 23 | MAPOS-UNARP | [Mitsuru_Maruyama][RFC2176] | ||
| 24 | OP_EXP1 | [RFC5494] | ||
| 25 | OP_EXP2 | [RFC5494] | ||
| 26-65534 | Unassigned | |||
| 65535 | Reserved | [RFC5494] |
ARP Hardware Codes
| 0 | Reserved |
| 1 | Ethernet |
| 2 | Experimental Ethernet |
| 3 | Amateur Radio AX.25 |
| 4 | Proteon ProNET Token Ring |
| 5 | Chaos |
| 6 | IEEE 802 Networks |
| 7 | ARCNET |
| 8 | Hyperchannel |
| 9 | Lanstar |
| 10 | Autonet Short Address |
| 11 | LocalTalk |
| 12 | LocalNet (IBM PCNet or SYTEK LocalNET) |
| 13 | Ultra link |
| 14 | SMDS |
| 15 | Frame Relay |
| 16 | Asynchronous Transmission Mode (ATM) |
| 17 | HDLC |
| 18 | Fibre Channel |
| 19 | Asynchronous Transmission Mode (ATM) |
| 20 | Serial Line |
| 21 | Asynchronous Transmission Mode (ATM) |
| 22 | MIL-STD-188-220 |
| 23 | Metricom |
| 24 | IEEE 1394.1995 |
| 25 | MAPOS |
| 26 | Twinaxial |
| 27 | EUI-64 |
| 28 | HIPARP |
| 29 | IP and ARP over ISO 7816-3 |
| 30 | ARPSec |
| 31 | IPsec tunnel |
| 32 | InfiniBand (TM) |
| 33 | TIA-102 Project 25 Common Air Interface (CAI) |
| 34 | Wiegand Interface |
| 35 | Pure IP |
| 36 | HW_EXP1 |
| 37 | HFI |
| 38-255 | Unassigned |
| 256 | HW_EXP2 |
| 257 | AEthernet |
| 258-65534 | Unassigned |
| 65535 | Reserved |
