MikroTik Simple Queue for VOIP


#########################################################################################################
#  MikroTik Simple Queue for VOIP                                                                       #
#########################################################################################################
# Author: Rick Frey                                                                                     #
# email: support@rickfreyconsulting.com                                                                 #
# Username in MikroTik Forum is rickfrey                                                                #
#########################################################################################################                                                                                        #
#########################################################################################################
# Features                                                                                              #                                                                             #
# -Provides 256K of bandwidth for each VOIP line.                                                       #
#########################################################################################################

############################################################################################################################
#### Step 1 - Copy the queue onto the router.                                                                             ##
#### Step 2 - Identify the VOIP traffic. In this example, 3 phones have bee identified by their IP address.               ##
#### Step 3 - Adjust the Parent Queue upload and download speed to max speed delivered to the router.                     ##
#### Step 4 - Adjust the VOIP queue and the "All Other Traffic" Queue so that their max upload and download is equal to or##
####          less than the Parent Queue.                                                                                 ##
#### Step 5 - Adjust the limit-at speed on the VOIP queue so that the speed is set to 250K X #_of_VOIP_Streams. In this   ##
####          example, there was three lines, so limit-at was set to 750K.                                                ##
############################################################################################################################


/queue simple

add max-limit=1M/25M name="Office Parent Queue" target=10.254.254.0/24
add limit-at=750k/750k max-limit=1M/2M name="VOIP Traffic" parent="Office Parent Queue" target=10.254.254.231/32,10.254.254.232/32,10.254.254.233/32
add max-limit=1M/25M name="All Other Traffic" parent="Office Parent Queue" queue=pcq-upload-default/pcq-download-default target=10.254.254.0/24

/

MikroTik Simple Queue for VOIP

 


Leave a comment

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

2 thoughts on “MikroTik Simple Queue for VOIP

  • Jhon Herrera

    Hi, i am starting learning mikrotik, thanks for this blog.
    I have one question, this script means:
    total bandwidth is 1 mbps for upload and 25mbps for download
    reserve 1mbps for upload for 3 host and assign 2 mbps download for 3 host
    the restant bandwind for the nework.

    it is true?
    thanks, regards from Colombia – South America

    • rickfrey1000 Post author

      Hi Jhon,

      The script is:
      One line #1, defining the amount of bandwidth that is available as a whole (1M up/ 25M down):
      add max-limit=1M/25M name=”Office Parent Queue” target=10.254.254.0/24

      The queue in line #2 is subordinate to the “Office Parent Queue” and is guaranteeing 750K/750K to the phones, but allowing them to use as much as 1M/2M if its available.
      add limit-at=750k/750k max-limit=1M/2M name=”VOIP Traffic” parent=”Office Parent Queue” target=10.254.254.231/32,10.254.254.232/32,10.254.254.233/32

      The queue in line #3 is also subordinate to the “Office Parent Queue” and is equally dividing the bandwidth of 1M/25M to however many users request if from the target subnet.
      add max-limit=1M/25M name=”All Other Traffic” parent=”Office Parent Queue” queue=pcq-upload-default/pcq-download-default target=10.254.254.0/24

      The overall idea here, that the phones always have bandwidth if they request it, but its shared if the phones are not using it.