RFC Identify Apple Updates


The text file version is located here: RFC_Identify_Apple_Updates

This script identifies Apple update servers so that they can be rate limited, paused, or blocked. The final action is not built out.

###################################################################################################
# Rick Frey Consulting Identify Apple Updates #
#########################################################################################################
# Author: Rick Frey #
# email: rickfrey1000@gmail.com #
# Username in MikroTik Forum is rickfrey #
#########################################################################################################
# License #
# This script has been created for use by the general public and may be used freely. #
#########################################################################################################
#########################################################################################################
# Features
# – Identifies Apple Update Servers
#########################################################################################################

/ip firewall address-list
add address=swscan.apple.com list=”Apple Updates”
add address=swquery.apple.com list=”Apple Updates”
add address=swdownload.apple.com list=”Apple Updates”
add address=swdist.apple.com list=”Apple Updates”
add address=swcdn.apple.com list=”Apple Updates”

/ip firewall mangle
add action=mark-packet chain=prerouting dst-address-list=”Apple Updates” new-packet-mark=”Apple Updates” passthrough=yes
add action=mark-packet chain=prerouting new-packet-mark=”Apple Updates” passthrough=yes src-address-list=”Apple Updates”
/

Leave a comment

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.