RFC Identify Microsoft Updates


The text file version is located here: RFC_Identify_Microsoft_Updates

This script identifies Microsoft update servers so that they can be rate limited, paused, or blocked. The final action is not built out.

###################################################################################################
# Rick Frey Consulting Identify Microsoft Updates #
#########################################################################################################
# Author: Rick Frey #
# email: rickfrey1000@gmail.com #
# Username in MikroTik Forum is rickfrey #
#########################################################################################################
# License #
# This script has been created for use by the general public and may be used freely. #
#########################################################################################################
#########################################################################################################
# Features
# – Identifies Apple Update Servers
#########################################################################################################

/ip firewall address-list
add address=windowsupdate.microsoft.com list=”Microsoft Updates”
add address=update.microsoft.com list=”Microsoft Updates”
add address=windowsupdate.com list=”Microsoft Updates”
add address=download.windowsupdate.com list=”Microsoft Updates”
add address=wustat.windows.com list=”Microsoft Updates”
add address=ntservicepack.microsoft.com list=”Microsoft Updates”
add address=go.microsoft.com list=”Microsoft Updates”

/ip firewall mangle
add action=mark-packet chain=prerouting dst-address-list=”Microsoft Updates” new-packet-mark=”Microsoft Updates” passthrough=yes
add action=mark-packet chain=prerouting new-packet-mark=”Microsoft Updates” passthrough=yes src-address-list=”Microsoft Updates”

Leave a comment

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.