RFC Unusual Protocols Chain


The text file version is located here: RFC_Bogon_Chain

 

#########################################################################################################
# Rick Frey Consulting Unusual Protocols Chain #
#########################################################################################################
# Author: Rick Frey #
# email: rickfrey1000@gmail.com #
# Username in MikroTik Forum is rickfrey #
#########################################################################################################
# License #
# This script has been created for use by the general public and may be used freely. #
#########################################################################################################
#########################################################################################################
# Features
# – Drops unusual protocols that should not be present on most networks.
#########################################################################################################

/ip firewall filter
add action=jump chain=input comment=”RFC Unusual Protocols” jump-target=”RFC Unusual Protocols”
add action=jump chain=forward comment=”RFC Unusual Protocols” jump-target=”RFC Unusual Protocols”
add action=drop chain=”RFC Unusual Protocols” comment=”Drop GGP (Gateway to Gateway Protocol – Obsolete)” protocol=ggp
add action=drop chain=”RFC Unusual Protocols” comment=”Drop GGP (Internet Stream Protocol – Obsolete)” protocol=st
add action=drop chain=”RFC Unusual Protocols” comment=”Drop EGP (Exterior Gateway Protocol – Obsolete)” protocol=egp
add action=drop chain=”RFC Unusual Protocols” comment=”Drop PUP (PARC Universal Packet Protocol – Obsolete)” protocol=pup
add action=drop chain=”RFC Unusual Protocols” comment=”Drop HMP (Host Monitoring Protocol – Obsolete)” protocol=hmp
add action=drop chain=”RFC Unusual Protocols” comment=”Drop XNS-IDP (Xerox Network Systems Internet Datagram Protocol – Obsolete)” protocol=xns-idp
add action=drop chain=”RFC Unusual Protocols” comment=”Drop XTP (Xpress Transport Protocol – Obsolete)” protocol=xtp
add action=drop chain=”RFC Unusual Protocols” comment=”Drop RSPF (Radio Shortest Path First – Not applicable to most people)” protocol=rspf
add action=drop chain=”RFC Unusual Protocols” comment=”Drop VMTP (Versatile Message Transaction Protocol – Not applicable to most people)” protocol=vmtp
add action=return chain=”RFC Unusual Protocols” comment=”Return from RFC Unusual Protocols”

Leave a comment

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.